[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Clearing the screen etc.
Symbolics has adopted "window" in place of "screen" in its
naming conventions. I think this is the right thing, and is
superior to both "screen" and "terminal" except possibly in cases
where the display operation really does refer to a screen
or a terminal.
Also, with respect to naming, let me plug my preference; rather
than add a lot of DO-THIS-OR-THAT functions, I'd rather add ONE
function, which encapsulates all screen operations. I have in mind
the general form;
(displayop <<displaystream>> <<operation>> &rest args)
This general form permits all "window" operations to be
recognized trivially, permits generic and implementation specific
extensions, and permits both "flavorized" and "macroized"
implementations. It also has the advantage of not polluting
the language with a lot more random function names.
The CL-WINDOWS mailing list (which I theoretically moderate)
is pretty moribund, mainly from the inability to sustain a
conversation. I have a feeling that each of the CL
implementations is pretty set in its own way of handling
displays, and the efficiency issues, combined with the
extremely low-level nature of display drivers, make any
compromise agreement on "standards" for fully elaborated
displays unlikely. As such, I support the idea of
chipping off this piece of the problem.