[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Date: Wed, 30 Jul 86 12:12 EDT
From: Bernard S. Greenberg <BSG@STONY-BROOK.SCRC.Symbolics.COM>
The name QUIT does not sound reasonable. Quit what? Is ease of typing
an issue, for something which is typed once per session and probably
appears once in even the largest subsystem? EXIT-LISP sounds much
better. I can easily (and have) had internal functions, and macros
called QUIT. I don't think the name should be used up in this way.
I agree with Bernie on this one. EXIT-LISP is better than QUIT. I used
to work on a system that had a very uniform command set and QUIT meant
"exit" from almost every one of the subsystems. Other system used EXIT.
If a programmer wants to put an escape out of lisp in their code then
EXIT-LISP is the right thing. Vendors may wish to incorporate their own
QUIT or EXIT functions so that users will know how to get out of the