> When *PRINT-STRUCTURE* in NIL: > I think a slightly better name is *PRINT-STRUCTURE-CONTENTS*. > (We've had this for a couple years). I agree on the utility of this variable, but not on its name. Since *PRINT-ARRAY* determines whether the contents of arrays are printed, a variable named *PRINT-STRUCTURE* should do the same for structures. Using *PRINT-STRUCTURE-CONTENTS* wouldn't be as clear.